Friday, August 23, 2019

Why Upgrade to EPM 11.2 or Move to the Cloud?

The title of this post is a question I get asked quite a bit.

By now, most on-premises customers have moved to Hyperion / Oracle EPM 11.1.2.4, which is the latest release currently available today

Upgrading on-premises can be a bit of a "project", depending upon how complex the environment is, and if any re-work is needed.  (For example: if you're on 11.1.2.3 or prior and using FDM Classic Edition, the FDM content has to be re-implemented into FDM Enterprise Edition as part of the upgrade to 11.1.2.4).

For this reason, many on-premises EPM shops tend to delay upgrades as long as possible.  Upgrades are usually disruptive to key end-users, and costs are involved from IT.  Consulting costs are also involved if you don't have deep EPM Infrastructure expertise in-house.  The typical upgrade cycle for many EPM customers, therefore, tends to be no more frequent than every 5 years.

There was a mad rush to upgrade to 11.1.2.4 a few years ago when Microsoft ceased support for all browsers older than IE 11.  I think we will again see a mad rush to either EPM 11.2 or the Cloud very soon.  Read on to find out why!

Operating Systems

The majority of on-premises EPM systems run on Microsoft platforms.  EPM 11.1.2.3 and older runs on MS Windows Server 2008 R2, and EPM 11.1.2.4 runs on either 2008 or 2012.

2008 is already out of Microsoft Extended Support.  2012 will come out of Extended Support on October 10, 2023.

In the case of UNIX variants, there many "flavors" of UNIX.  The most popular one where EPM is concerned is Red Hat Enterprise Linux (RHEL).  Both EPM 11.1.2.3 and 11.1.2.4 are certified to run on RHEL 6.  Where RHEL 6 is concerned, we refer to the chart below.

(Content cropped from https://access.redhat.com/support/policy/updates/errata)

So RHEL6 was released in 2010, and depending upon which support package your IT department purchased, it is either out of support now, or is coming out of support soon.

Database

The two most popular databases for EPM 11.1.2.4 I've seen "out in the wild" are MS SQL Server 2012 R2 and Oracle Enterprise Database 12.x.  EPM 11.1.2.3 runs on MS SQL Server 2008 (SP3 should have been applied by now) and an older version of Oracle 12 or lower.

Let's talk about MS SQL Server first, as that one is slightly more popular than Oracle, as far as I've observed.  Again, let's refer to the chart.

(Source: Google search "MS SQL Server End of Life")

IT Departments

Both from an Operating System and Database perspective, Finance will be pressured by IT to upgrade, due to operating system support.  IT highly frowns on running systems that are out of vendor support!  (As a former IT guy myself, I know all too well how IT shops run internally, and how Compliance and/or Risk Management departments can tend to be a bit inflexible in this regard).

Hyperion / Oracle EPM

If you are running 11.1.2.3 or older, the clock has already run out.  You are on what is called Lifetime Support.  In Plain English(TM), this means:
  • No new defect fixes
  • No new security patches
  • Access to the Knowledge Base
  • Access to previously issued patches
If you're on 11.1.2.4, which most of you should be on by now, you are still getting defect fixes and security patches, but the clock is ticking.  Let's refer to the Oracle Knowledge Base, article # 2251273.1.  I  won't paste the whole thing here, but here's the key nugget of information:

"... the end of Premier Support moved from December 2018 to December 2020.  The end of Extended Support remains at December 2021."
(Source: Oracle Corporation)

This means according to the Oracle Support package your company purchased, you either have until Dec 2020 or Dec 2021 to either upgrade or move to the Cloud.

Java

EPM 11.1.2.0 through 11.1.2.4 ship with Java SE 6 and JRockit 6.  Only EPM 11.1.2.4 is certified to replace Java 6 and JRockit 6 with Java SE 7 (see: http://www.epmonprem.pro/2018/07/upgrading-to-java-7-for-epm-11124-it.html)

Chart time!

(Source: https://www.oracle.com/technetwork/java/java-se-support-roadmap.html)

EPM Customers who are still paying their Oracle maintenance are on the "Extended Support" column as shown above.

Java 6 and JRockit 6 came out of support at the end of 2018.  As of this writing, Oracle is still issuing Quarterly security patches for Java 7.

EPM 11.2 is expected to ship with Java 8.  This would extend Java's support lifetime through March 2025.  It is my hope that Oracle issues a certification and upgrade instructions to let us upgrade the servers to Java 9 sometime before March 2025.  Otherwise, we'd be looking at a potential security problem in the future.

Conclusion

Look at all of the support expiration dates above, and we see the shortest "lifetime" is the one for EPM 11.1.2.4.

If you don't think EPM 11.2 will be ready in time for a 2020 upgrade, or if your 2020 budget has already been established, then either switch over to Oracle's Extended Support plan or start looking at the Cloud.  (Note: the Cloud isn't for everyone.  There are some cases where it is a perfect fit, and other cases where the on-premises applications are too mature and integrated with each other.)

A big benefit of the Cloud is that once you've migrated into the Cloud, you will never again have to worry about future upgrades required by support expiration dates.  It is a double-edged sword, however: you need to regression test the monthly automatic Cloud updates.

I hope this information has been helpful.  Keeping track of all of these support expiration dates can be a real pain sometimes!






No comments:

Post a Comment